create-react-app@next支持css,less modules问题

最近使用create-react-app构建项目时,需要使用less并且支持modules,不想使用eject,所以使用了react-app-rewired+react-app-rewire-less-modules的方式。但是…构建时仍然抛错。搜寻良久,发现是create-react-app版本问题,于是按照最新的@next版本,然而还是报错。仔细分析了升级的部分,通过package.json的依赖包看错,react-scripts使用还是1.X版本,尝试升级react-scripts到@next版本。然后构建,一切OK!


2019年2月15日更新:

最新版的react-app-rewired配合customize-cra已经完全支持了less及模块化,不需要引入其它的插件了。快速搭建项目脚手架可以参考https://github.com/rt-zhangxuefei/react-startup

reactjs
作者:张雪飞
出处:https://zhangxuefei.site/p/2150
版权说明:欢迎转载,但必须注明出处,并在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

发表评论

电子邮件地址不会被公开。 必填项已用*标注